Welcome back! Ask questions, get answers, and join our large community of tax professionals.
cancel
Showing results for 
Search instead for 
Did you mean: 

Electronic filing

Highlighted
Level 2

Good evening Community.

I'm having a problem and I wonder if anyone can be of help. I get an error message when  attempting to efile  a tax return.  Both the federal and the state return are being converted but neither will transmit.  The error message reads "Invalid Filer Id.  Must be a valid SSN or EIN. ID="

I transferred the client data from last year and verified the SSN is correct.  I've updated the product, run and re-run final reviews with no errors.  I've even already successfully efiled other returns both before and after attempting to efile this problem return.

Any suggestions on what could be the problem?

Thanks

Labels (1)
0 Cheers
1 Solution

Accepted Solutions
Highlighted
Level 15
Level 15

You need to refresh updates.  I think Basic also has the Update Repair tool (or maybe its called Refresh Updates) in the Windows Program menu.  It dumps the bad update files that are causing the error, then you run updates again and you should be back in business.


♪♫•*¨*•.¸¸♥Lisa♥¸¸.•*¨*•♫♪

View solution in original post

4 Replies 4
Highlighted
Level 11
Level 11

Did not know it extended to Basic. There has been lots of people with this issue and has been reported in this forum. My advice is to search these prior posts and within a page or two, you should find a solution I believe.

Highlighted
Level 15
Level 15

You need to refresh updates.  I think Basic also has the Update Repair tool (or maybe its called Refresh Updates) in the Windows Program menu.  It dumps the bad update files that are causing the error, then you run updates again and you should be back in business.


♪♫•*¨*•.¸¸♥Lisa♥¸¸.•*¨*•♫♪

View solution in original post

Highlighted
Level 2

Refreshed updates.  Updated installed products.  Problem solved.  

Thank you

0 Cheers
Highlighted
Level 1

I have the same problem.  Returns convert, but the only message I get is "Return not transmitted." No errors stated.  I've restarted my computer and clicked on Refresh Updates - Refresh Updates for Installed Products, but still cannot transmit.

0 Cheers