Welcome back! Ask questions, get answers, and join our large community of tax professionals.
cancel
Showing results for 
Search instead for 
Did you mean: 

All of my returns show "US" in the "name of foreign country" address field. Is there a way to remove this?

Highlighted
Level 1
 
Labels (1)
0 Cheers
1 Solution

Accepted Solutions
Highlighted

You have to check the box for Foreign address in the client information section that way it makes it so that the input for country is no longer grayed out. Then you have to put the country selection back to select and then uncheck the box for Foreign address

View solution in original post

0 Cheers
28 Replies 28
Highlighted
Level 15
Which input screen are you referring to?  In PTO, there is not a field called "name of foreign country" as far as I am aware, even on the forms related to international returns.  The way PTO is configured, you would need to first check the box for "Foreign Address" before you are given the option to select a foreign country from the dropdown box for "Country".

Could you clarify?
---------------------------------------------------------------------------------
Still an AllStar
0 Cheers
Highlighted
Level 1
I'm sorry...On the 1040 Form itself, address shows, as usual, but the last line where it is labeled "Foreign Country Name " shows as "US".  All clients addresses show that way on forms and letters.
0 Cheers
Highlighted
Level 15
When you look at the 1040 - Click on the US and see what input it takes you to. I can not get a return to do this. Even when I check Foreign Address, US does not seem to be a choice.

ex-AllStar
0 Cheers
Highlighted
Level 15
@lpacitto.cpa Can you upload a screenshot of the page and line item you are referring to?
---------------------------------------------------------------------------------
Still an AllStar
0 Cheers
Highlighted
Level 1
When I look at 1040 the line with the foreign address is not blue (you can't drill down).  I'm going to have to call support...It's not hurting anything, just looks weird.
0 Cheers
Highlighted
Level 1
Did you ever find a solution to this? I have noticed it showing up on returns I have newly created this season, and not on ones that have carried over from last.
0 Cheers
Highlighted
Level 1
No, I have not called support yet.  Will keep let you know when I do!
0 Cheers
Highlighted
You have to check the box for Foreign address in the client information section that way it makes it so that the input for country is no longer grayed out. Then you have to put the country selection back to select and then uncheck the box for Foreign address
0 Cheers
Highlighted
Level 1
Thank you!!
0 Cheers
Highlighted
Level 1
Worked! Thanks.
0 Cheers
Highlighted
Level 1
Thanks for providing a great answer. We had the same problem and it worked.
0 Cheers
Highlighted
Level 1
Thanks so much!  It worked for me!
0 Cheers
Highlighted
Level 1
I am having same problem this year, but it is my client letters that show US in last address line.  The above solution from last year is not working.  Is anyone else having this problem????
0 Cheers
Highlighted

You have to check the box for Foreign address in the client information section that way it makes it so that the input for country is no longer grayed out. Then you have to put the country selection back to select and then uncheck the box for Foreign address

View solution in original post

0 Cheers
Highlighted
Level 15

Click the box for Foreign Address


ex-AllStar
0 Cheers
Highlighted
Level 8
Amazing that you got two Not Helpfuls for the correct answer!
0 Cheers
Highlighted
Level 15
I need a raise!

ex-AllStar
0 Cheers
Highlighted
Level 15
We love unhelpful votes, don't we?  We just don't understand why, especially when the answer is correct.
---------------------------------------------------------------------------------
Still an AllStar
0 Cheers
Highlighted
Level 8
And then there were three.
0 Cheers
Highlighted
Level 15
What do you do when the world sends you lemons? You make lemonade with them.
---------------------------------------------------------------------------------
Still an AllStar
0 Cheers
Highlighted
Level 8
I have a rotten cold and am off to bed with lemonade with honey in it right now!!
0 Cheers
Highlighted
Level 15
Put some brandy in there too, Jane.   It helps, or at least makes you not care.
Feel better soon.
Former Chump... umm.... AllStar.
If a post answers your question, click on *Accept as solution* for future searches
0 Cheers
Highlighted
Level 1
"Click the box for Foreign Address" is the equivalent of "Open the Client's tax return". Both are starting points, and also not very helpful for this issue. I suspect 3, will become 4, maybe 5......as this tax season continues on.
0 Cheers
Highlighted
You have to check the box for Foreign address in the client information section that way it makes it so that the input for country is no longer grayed out. Then you have to put the country selection back to select and then uncheck the box for Foreign address
0 Cheers
Highlighted
Level 15
That's a piss poor design/programming feature.

ex-AllStar
0 Cheers
Highlighted
Level 15
@sjrcpa - I THINK this only happens if you click Foreign Address when you first start. I have never encountered this, so that is why I got an UNHELPFUL for my answer. I am quite confident it is a PEBCAK issue.

ex-AllStar
0 Cheers
Highlighted
Level 15
@George4Tacks Agree. Never had a problem with this.
---------------------------------------------------------------------------------
Still an AllStar
0 Cheers
Highlighted
Level 15
Thanks

ex-AllStar
0 Cheers