ProConnect HelpIntuit HelpIntuit

Troubleshooting ProSeries error when opening clients - "Unable to read the data. Exit program and try again"

SOLVEDby IntuitProSeries Basic5Updated March 22, 2022

Before you start:

  • This article references default installation paths and uses YY to reference the tax year in 20YY format. C: will always indicate the local drive and X: will always indicate the network drive.

ProSeries has a new tool that can attempt to repair data corruption in ProSeries 2020. To run the repair:

  1. Close ProSeries.
  2. Download the ProSeries Tool Hub Install file. Save the file  somewhere you can easily find it (like your Downloads folder or your Windows desktop).
  3. Open the file you downloaded (ProSeriesToolsHub_Setup.exe).
  4. Follow the on-screen steps to install and agree to the terms and conditions.
  5. When the install finishes, double-click the icon on your Windows desktop to open the Tool Hub.
    PCG_PS_TH_Icon.png

If you can't find the icon, do a search in Windows for ProSeries Tool Hub and select the program.

Step 2: Using the tool in the ProSeries Tool Hub

  1. Open the ProSeries Tool Hub.
  2. Select Corruption Repair on the left.
  3. Click on ProSeries Corruption Repair Utility.
    PCG_PS_TH_Corruption.png
  4. Follow the on-screen instructions to run the tool.

If the ProSeries Corruption Repair Utility doesn't resolve the issue, or if the error is happening in ProSeries 2019 or prior attempt, the following. After each solution, attempt to open the file again.

If the Tool Hub doesn't fix the error these manual steps can sometimes reverse the damage:

  1. From the File menu, select Save As.
  2. Choose a slightly different file name.
  3. If the new file name works, delete the original file.
  4. If the issue persists, try switching to another printer by going to File and selecting Print Options.
  1. Close ProSeries.
  2. Browse to the Data folder:
    • ProSeries stand-alone default is  C:\ProWinYY\YYData
    • ProSeries Basic default is C:\BasWinYY\YYData
    • ProSeries Network installs default is X:\ProNetYY\YYData
  3. Locate any .tmp files that start with a ~ or a $.
  4. Right-click and choose Rename.
  5. Change the .tmp file to a .YYi file
  6. Open ProSeries.
  7. Open the renamed file and check the information
  8. If the information is correct, go to the File menu and choose Save As.
  1. Open ProSeries
  2. ​From the Tools menu, select Options
  3. From the left side, select Firm / Preparer Info.
  4. If your firm and preparer information is correct, proceed to Solution 3. If your firm and preparer information is missing, continue with these steps.
  5. Close ProSeries and browse to the Common folder.
    1. ProSeries stand-alone default is  C:\ProWinYY\Common
    2. ProSeries Basic default is C:\BasWinYY\Common
    3. ProSeries Network installs default is X:\ProNetYY\Common
  6. Right-click on SHRFRMYY and select Rename.
  7. Change the name to SHRFRMYYOLD.
  8. ​Open ProSeries
  9. From the Tools menu, select License Products.
  10. Attempt to open the client file again. If the error is still present, continue with Solution 3.
  1. Close ProSeries.
  2. Browse to the Data folder:
    • ProSeries stand-alone default is  C:\ProWinYY\YYData
    • ProSeries Basic default is C:\BasWinYY\YYData
    • ProSeries Network installs default is X:\ProNetYY\YYData
  3. Locate any .tmp files that start with a ~ or a $.
  4. Right-click on the files and choose Cut.
  5. Go to your Windows Desktop, right-click and choose Paste.
  6. Open ProSeries.
  7. Try to open the client again.
  1. If the client file opens but doesn't save, Backup the client file to a new location. For more information see How to Copy or Backup Client Files Using ProSeries
  2. Verify a copy of the file has been created in the backup location.
  3. Delete the client file from the ProSeries Professional Edition HomeBase by clicking on the File Menu
  4. Select Client File Maintenance and select Delete.
  5. Restore the client file from the backup just made. For more information see Restoring Client Data Files Using ProSeries

If none of the above solutions work the client file is corrupt beyond repair and must be restored from a prior backup, recreated, or transferred from the prior year. You may need to delete the corrupt file and re-enter the data.

Data corruption can occur if conflicts exist between ProSeries and other applications installed on the computer. The most typical configuration issues occur with antivirus software, though other software can cause conflicts that may lead to data corruption. If this issue reoccurs, try contacting an IT professional to help in configuring software on your computer to limit possible conflicts. For more information on how to configure antivirus software, see How to exclude ProSeries from real-time system scans.

Try each solution below before proceeding with the next solution.

  • The 'shared form' file may be damaged and will need to be renamed. This file is responsible for storing preparer information, rates per form, and global billing options.  Renaming this file may result in the loss of the information. You'll need to re-enter this information when ProSeries is re-opened.
    1. Close ProSeries.
    2. Browse to the Common folder:
      1. ProSeries stand-alone default is  C:\ProWinYY\Common
      2. ProSeries Basic default is C:\BasWinYY\Common
      3. ProSeries Network installs default is X:\ProNetYY\Common
    3. Find the SHRFRMYY file.
    4. Right-click on the files and choose Rename.
    5. Put old at the end so its called SHRFRMYYold
    6. Open ProSeries.
    7. Try opening the client files.
  • If the error is happening in ProSeries 2019 or prior:
  • If still unresolved, rename and reinstall the program:

If none of the above resolved the error:

Related topics

It is also suggested to run Disk Cleanup, Scan Disk, and Disk Defragmenter:.  As always, it's best to instruct our customers to seek outside assistance if we determine their issue is system/hardware related.

Additionally, this error will sometimes appear after ProSeries terminates unexpectedly.  Attempting to open the client file directly or copy it from YYData folder results in a message resembling "You require permission from this computer's administrator to make changes to this file".

Reboot the computer (if stand alone) or the workstation and server (if network).  After the reboot, verify the affected client has disappeared from YYData.  This is expected since the file could not be read, but the file system did not refresh.  Repair the HomeBase (and delete any lingering JN1 files) so the client file can be restored from backup or created anew.

Was this helpful?

You must sign in to vote, reply, or post
ProSeries BasicProSeries Professional

Sign in for the best experience

Ask questions, get answers, and join our large community of Intuit Accountants users.