Lacerte Tax 2016 System Recommendations

(Including Add-Ons: Tax Planner, Tax Analyzer and eOrganizer)

Keep your system updated and achieve more productivity during tax season

 

Don't lose speed and productivity during tax season. Make sure your Intuit ProConnect Lacerte software runs optimally and ensure compliance by checking your system against our system recommendations below. Upgrading will keep you from having unnecessary slowdowns, hassles and a less-than-optimal experience. More importantly, it will allow for further productivity during the busy tax season.

 

 

Recommended system requirements for enhanced performance

 

 

Windows 10, Windows 8 or Windows 7:

Please check to see if your computer's memory meets our system recommendations.

 

Attention Windows XP Users:

In line with Microsoft's recent decision to discontinue support of Windows XP, Intuit ProConnect also stopped supporting this operating system upon the release of our TY14 tax program, which means you will not be able to install it in a Windows XP environment. You will want to upgrade your operating system to Windows 7 or higher in order to continue running your Intuit ProConnect software.

Go to the Microsoft Help and Support page to update your software

 

If you are using Windows 10, Windows 8, Windows 7 or Vista:

Check to see if your computer's memory meets our system recommendations

Click Start on the taskbar, Right-click My Computer or   Computer, then Select Properties

 

What to expect for Windows 10, Windows 8, Windows 7 or Vista:

In certain cases where you have a system that is 3 years old or older we suggest you check to see if you have a dual-core processor

Click Start on the taskbar, Right-click My Computer or Computer, then Select Properties

 

Common names of dual-core processors

 

 

System Recommendations

 

Processor:

2.4 GHz dual core processor

 

Memory (RAM):

Varies by operating system 3 GB RAM for 32-bit operating systems 4 GB RAM for 64-bit operating systems

 

Hard Disk Space:

4 GB of hard disk space free

 

Monitor:

19" with screen resolution of 1920 x 1080 or higher

 

Printer:

Laser printer with a print speed of at least 17 ppm and a minimum of 32 MB RAM.

 

CD Drive:

32X CD-ROM or faster

 

Internet Connection:

High-speed, such as DSL, or Cable/Broadband is required to license the software, download Web release and Internet Updates, and transmit e-File, pay per return authorization or service request submissions.

 

Browser:

Internet Explorer 10.0 or greater with 128-bit encryption

 

Add-on Components:

Microsoft .NET Framework 4.5

Note: Must be installed manually for Windows Vista and 2008 Server. Windows 7 and Windows 8 automatically ships with this component. To download, click here.

 

Supported Operating Systems:

Windows Vista Professional or higher (32-bit & 64-bit), Windows 7 Professional (Service Pack 1) or higher (32-bit & 64-bit) and Windows 8 Professional or higher (32-bit & 64-bit).

 

Supported Network Servers:

Windows Server 2008 R2 (includes Small Business Server), Windows Server 2012 R2, Windows Vista and Citrix Server (on Windows Server 2008 R2).

For more details on Network Administration and Citrix, please refer to the Lacerte resource guides.

 

Note:

If your firewall requires specific port configuration, please click here to configure these ports to allow outbound/inbound TCP traffic.

 

 

Frequently Asked Questions

 

Why will Lacerte 2016 not install on Windows XP?

Microsoft no longer provides operating system updates to Windows XP, which means PC's running Windows XP may become vulnerable to security flaws and other issues. Because Lacerte is designed to handle sensitive taxpayer data securely, we have made the decision to only support operating systems that meet current security standards. Windows XP no longer meets that standard. We began communicating this change in 2013 to provide customers with enough time to upgrade.

 

Can I keep my Windows XP computer for prior year programs?

Yes. Microsoft no longer provides updates for XP. Since December 31, 2014, Lacerte will not update the 2013 and prior year programs. The prior year programs should continue to run as they do today. Prior years that are still open for e-File, can still be e-Filed from XP systems, but we encourage users to upgrade open years to supported operating systems.