Welcome back! Ask questions, get answers, and join our large community of tax professionals.
cancel
Showing results for 
Search instead for 
Did you mean: 

My passsword is showing up automatically when i sign in...how to i stop that

Highlighted
Level 1
 
Labels (1)
0 Cheers
3 Replies 3
Highlighted
Level 15

There is a button to check to "remember me".  Are you 'unchecking' that button when you are logging in?

Former Chump... umm.... AllStar.
If a post answers your question, click on *Accept as solution* for future searches
Highlighted
Level 15
Level 15

I thought Remember Me only saved the UserID, I didnt realize there was a way to have the password autofill


♪♫•*¨*•.¸¸♥Lisa♥¸¸.•*¨*•♫♪
Highlighted
Level 15

Evidently, you have already agreed to the browser saving your password for Intuit login.  The way to undo this would depend on the browser you use.

  • Chrome: Settings > Autofill.  There, you'll see a list of "Saved Passwords".  Click on the 3-dots and choose "Remove".
  • Firefox: Click on the 3-bars on the top-right-corner.  Select "Logins and Passwords".  You'll see a list of the websites for which you have saved the passwords.  Select the one for Intuit and click on the "Delete" button on the right.
---------------------------------------------------------------------------------
Still an AllStar